問題発覚

どうやら、PHP5.1.XからPHP5.3.Xにすると切り捨てられてサポートしていない関数や レガシーなコードがいくつかあるらしく、あるページで使われている掲示板のシステムが エラーを起こしてました。

具体的に引っかかったのが下記のようなコードです。

$aaa =& new BBB();

上記のコードでnewの前に「&」を使ってはいけないらしく、 PHP5.3.Xからは下記のように書かないとダメみたいです。

$aaa = new BBBBB();

それをコード全体で使われていて全て置換してみましたが、 それでもダメでまだレガシーな記述方法が残っているみたいで、 このままトライアンドエラーしても時間ばかり掛かるので、 別の方法を模索してみようかと思います。

いいね! 0